MayaaでGuice2.0 AOPを使うとうまく動かない件〜解決編

http://d.hatena.ne.jp/s-ishigami/20090906/1252210901 の続きです。
MLにてsugaさんに回答いただき、無事解決することができました。感謝です。

解決方法

Mayaa Blank Warにバンドルされているrhino-1.7r.jarを使用せず、下記URLよりRhino最新版を入手して、その中のjs.jarを使用する。
http://www.mozilla-japan.org/rhino/download.html

解説

Rhinoには、js.jarとjs-14.jarの2種類のjarファイルが存在し、前者はJava5以上、後者はJava1.4でも動くとのことです。

Guiceを使っているならJava5なので、Guice+Mayaaの組み合わせはこれで問題なさそうです。


コメントを残す

メールアドレスが公開されることはありません。